PHP v5.2 je dosegnuo svoj kraj života i više nije podržan od strane PHP projekta. To znači da se više ne izdaju sigurnosna ažuriranja i da bi zadržali servere i web stranice sigurne, potrebna je nadogradnja na PHP v5.3.

Nadogradnja na serverima planirana je za  31.03.2013.

Što za vlasnike web stranica znači nadogradnja PHP-a na verziju 5.3? Dobra vijest je da je mnogo popularnog PHP softvera već kompatibilno sa PHP v5.3., a za stranice koje koriste vlastite PHP skripte (ili nemaju kompatibilnu verziju) postoje vrlo jednostavna rješenja koja se mogu primijeniti.




Nekoliko popularnih softvera kompatibilnih sa PHP v5.3

Zen Cart je kompatibilan sa PHP v5.3 od verzije 1.3.9.a. Budući da starije verzije imaju ozbiljne sigurnosne propuste, sve stranice koje koriste stariji Zen Cart trebalo bi nadograditi na verziju 1.3.9 što je prije moguće. Posljednja verzija Zen Cart-a trenutno je 1.5.0 i može se preuzeti na www.zen-cart.com ili automatskom instalacijom preko cPanel Softaculous paketa koji je dostupan na svakom na�em serveru.

osCommerce je kompatibilan sa PHP v5.3 od verzije MS2.3.0

Magento je kompatibilan sa PHP v5.3 od verzije 1.4.0. Starije verzije 1.3.x nisu kompatibilne

PrestaShop je potpuno kompatibilan sa PHP v5.3 od verzije 1.3, izdane 25.05.2010.

openCart je kompatibilan sa PHP v5.3 od verzije 1.3.1, izdane u 8. mjesecu 2009.

WordPress nema točne informacije od koje verzije je kompatibilan sa PHP v5.3, no svakako bi trebali redovno raditi ažuriranje. Verzije od 3.0 na više svakako će raditi sa PHP v5.3.

Joomla! je potpuno kompatibilan sa PHP v5.3 od verzije 1.5.15 . Nadogradnja na verziju 2.5 je svakako preporučena budući da se verzija 1.5 više ne nadopunjuje sa sigurnosnim zakrpama i nema službenu podršku Joomla developera. Automatska instalacija i nadogradnja dostupna je preko cPanel Softaculous paketa koji je instaliran na svakom našem serveru.

CMS Made Simple je potpuno kompatibilan sa PHP v5.3 od verzije 1.7 � Cape Verde, izdane u 3. mjesecu 2010.

Ostali web softver  u ovom članku spomenute su samo najčešće korištene web skripte, no to ne znaći da druge skripte koje koristite na svojim web stranicama nisu već kompatibilne. Prvi korak bi bio da provjerite dokumentaciju instaliranog softvera, provjerite na službenoj stranici ili ako projekt ima forumu pitajte zajednicu korisnika tog softvera da li je vaša verzija kompatibilna sa PHP v5.3.

Ako koristite vlastito napisanu stranicu/skriptu, prvo pokušajte kontaktirati tvrtku koja vam je izradila stranicu. Ako to više nije moguće, tada razmislite o unajmljivanju PHP developera koji će vam provjeriti stranicu i nadograditi je da podržava PHP v5.3.

ionCube kodirani softver bi trebao raditi bez ikakvih izmjena, no ako niste sigurni kontaktirajte dobavljaća softvera.



PARIS - uslužno informatički obrt

 



Monday, February 4, 2013



« Nazad

Powered by WHMCompleteSolution